T-Plan Home
T-Plan Robot Enterprise 3.5.1 Doc Collection
GUI Reference
11/04/14

T-Plan Robot Enterprise 3.5.1 GUI Overview

T-Plan Robot Enterprise Graphical User Interface (GUI) is based on Java Swing and is platform independent. It consists of the main application window and a set of child windows (dialogs).

Login Window
  1. Menu and Tool Bar provide structured access to most of the application functionality.
    Help Topic:  T-Plan Robot Enterprise 3.5.1 Menu And Tool Bar Reference
  2. Tool Panel is a tabbed pane allowing quick access to often used minor features working with functionality of the script editor, desktop viewer and/or the underlying desktop client.
    Help Topic:  T-Plan Robot Enterprise 3.5.1 Tool Panel
  3. Script Editor is designed to enable easy script editing and execution. It provides a wide range of features, from scripting language syntax highlighting and GUI assisted composure of automation code to abilities to execute just the selected piece of code and to set up execution break points.
    Help Topic:  T-Plan Robot Enterprise 3.5.1 Script Editor
  4. Desktop Viewer displays desktop of the system under test (SUT). When the tool is not connected or it works with the local desktop, the viewer displays an HTML document with links to documentation and other web resources.
    Help Topic:  T-Plan Robot Enterprise 3.5.1 Desktop Viewer
  5. Status Bar is used by all components to display status messages, desktop update rectangle and mouse coordinates.
    Help Topic:  T-Plan Robot Enterprise 3.5.1 Status Bar



A catalog of child windows ordered by their appearance in the menu/tool bar follows:

Project
              Properties
The New Project and Project Properties create and/or edit a project. The window can be opened through the File->New Project menu item or through the New Project or Project Properties menu items of the Project View root node right click context menu. 

Help Topic:  T-Plan Robot Enterprise 3.5.1 Projects
New Script
The New Script window creates a new test script and populates it with the basic settings of output and template paths and the result file (report). It is available through the File->New Script menu item or through the New Test Script menu item of the Project View test script node right click context menu.
Java Converter
The Conversion To Java wizard exports TPR test script(s) (*.tpr) to Java source code (*.java). It is available through the File->Export To Java menu item or from the TPR editor context menu.

Help Topic:  Conversion To Java
Search &
              Replace
The Find/Replace is a very simple window allowing to search and eventually replace strings in the active script editor. It may be opened through the Edit->Find/Replace menu item or the corresponding tool bar button.
Go To Line
              Window
The Go To Line allows to jump to a particular line number in the active script editor. It is available through the Edit->Go To Line menu item.
Code Templates
The Code Templates window allows to create and maintain test script code templates. It is available through the Edit->Code Templates menu item.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Code Templates
Preferences Window
The Preferences Window enables to edit application wide configuration parameters and customize T-Plan Robot Enterprise behavior. It has a form of a tree where each tree node represents a topic and/or a particular component. A panel with available configuration parameters is displayed on the right when the tree node gets selected. The window may be started through the Edit->Preferences menu item or the corresponding tool bar button. Many components also provide quick links to their configuration tree node through a context (pop up) menu.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Preferences Window
Screenshot Command Window
The Screeenshot Command window provides a comfortable way of creating an instance of the Screenshot command in the active editor. It may be started through the Script->Screenshot Command menu item or the corresponding tool bar button. It is also possible to open the window through the context menu (right mouse click) of an already existing Screenshot command in the active editor.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Screenshot Command Window
CompareTo Command Window
The CompareTo Command window provides a comfortable way of creating an instance of the CompareTo command in the active editor. It may be started through the Script->CompareTo Command menu item or the corresponding tool bar button. It is also possible to open the window through the context menu (right mouse click) of an already existing CompareTo command in the active editor.

Help Topic:  T-Plan Robot Enterprise 3.5.1 CompareTo Command Window
WaitFor Command Window
The WaitFor Command window provides a comfortable way of creating an instance of the WaitFor match and mismatch commands in the active editor. It may be started through the Script->WaitFor Command menu item or the corresponding tool bar button. It is also possible to open the window through the context menu (right mouse click) of an already existing WaitFor command in the active editor.

Help Topic:  T-Plan Robot Enterprise 3.5.1 WaitFor Command Window
Image Doctor Records
The Image Doctor Records window keeps track of failed image comparisons collected by the Image Doctor. It may be opened through the Script->Image Doctor Records menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Image Doctor
Image Doctor Warning
The Image Doctor Warning window gets displayed when an image comparison fails while a script is being executed and the Image Doctor wizard is on.

Help Topic: T-Plan Robot Enterprise 3.5.1 Image Doctor
Login Window
The Login Window allows to connect to a desktop. It displays as the very first window when the application gets started without any connection options. The window is also reachable through the Desktop->Connect Desktop and under certain conditions also Desktop->Reconnect Desktop menu items.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Login Window
Keyboard Tool
The Keyboard Tool allows to construct a keyboard key and press it on the remote desktop and/or insert the corresponding command or Java method call into the active test script editor. The tool may be started through the Tools->Keyboard Tool menu item.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Keyboard Tool
Take A Screenshot Window
The Take A Screenshot window allows to save image of the current desktop or its rectangular part to a file. It is accessible through the Tools->Take A Screenshot menu item.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Take A Screenshot
Plugin Manager Window
The Plugin Manager allows to install, enable, disable and uninstall plugins. To open it select the Tools->Plugins menu item.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Plugin Manager Window
Component Capture
              Window
The Component Capture component offers a comfortable way of creating a template image directly from the desktop viewer and generating of a predefined action into the active script editor.

Help Topic:  T-Plan Robot Enterprise 3.5.1 Component Capture
Import
                T-Plan Script Window
The Import T-Plan Script creates an automated script template based on a script entity in the T-Plan database. The window is part of integration with T-Plan Professional 7.0. To open it select the Tools->Import T-Plan Script menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Integration Reference
Import T-Plan
                Script Window The Export Results To T-Plan exports results from automated testing to the T-Plan database. The window is part of integration with T-Plan Professional 7.0. To open it select the Tools->Export Results To T-Plan menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Integration Reference
License Key Manager Window
The License Key Manager is a simple window allowing to add or remove license keys. It displays automatically on startup when no valid license is installed. It is also available through the Tools->License Key Manager menu item. Role of license keys is described in the T-Plan Robot Enterprise Release Notes.
Update &
              Upgrade The Update & Upgrade window exposes T-Plan Robot Enterprise releases from the T-Plan release server and allows to download new software versions and/or upgrade the current installation. To open it select the Tools->Update & Upgrade menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Update & Upgrade
Result Manager
The Result Manager keeps track of results produced by test scripts since the application start and allows their viewing, editing and saving. It displays automatically when a manually executed script in GUI mode finishes and produces a set of results. It is also available through the Tools->Result Manager. The window may be also displayed in CLI mode when the -m/--resultmanager CLI option is specified.

Help Topic: T-Plan Robot Enterprise 3.5.1 Result Manager
Comment Exporter
The Export Script Comments window allows to process comments present in the main script body and export them to a file. It is available through the Tools->Export Script Comments menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Comment Exporter
Character Image
              Capture
The Character Image Capture wizard creates and maintains character image collections used by the Image Based Text Recognition algorithm . It is available through the Tools->Character Capture menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Image Based Text Recognition
About Window
The About Window is available through Help->About and displays the copyright and license text as well as system properties (configuration) of the Java Runtime Environment (JRE).
Log Viewer
The Log Viewer displays the available T-Plan Robot Enterprise application logs capturing the messages printed into the standard and error output streams (typically the console/terminal or command prompt). It is available through the Help->Log Viewer menu item.

Help Topic: T-Plan Robot Enterprise 3.5.1 Log Viewer
Help Window
The Help Window displays content of the help topics bundled inside the T-Plan Robot Enterprise binaries. User can also select to open the help document in a web browser instead. The help content is available either through the Help->Help Topics menu item or the "Open Help" and "Contextual Help" tool bar buttons. Many components also provide quick links to their help topics.
Template Image
              Editor The Template Image Editor allows to edit template images employed for image comparison. The window is available from any GUI component involved in image comparison, such as the CompareTo, Screenshot and Waitfor match/mismatch windows.

Help Topic:
T-Plan Robot Enterprise 3.5.1 Template Image Editor